
How to built a QCX SSB from a new QCX Kit with Rev 5 PCB. Documentation by DL2MAN

Introduction:
When I did the QCX SSB Modification (by Guido PE1NNZ) following his Instructions, I had 
several Points, that caused me headache. For Example: Where to put the missing Parts from his Rev
4 PCB in Rev 5 PCB ? So I ended up with 3 printed out Schematics (Rev 4, Rev 5 and QCX SSB), 
comparing them for hours, and trying to figure out where to put what.... 
So I had the Idea to do a step by step documentation, so future builders will have it easier.
This is not intended as a full manual for the QCX SSB, but only as building aid for other HAMs.

What do you need ?

1. QCX Kit from QRP Labs http://shop.qrp-labs.com/qcx
2. If you want multiple Bands, a low pass filter for each Band http://shop.qrp-

labs.com/kits/LPF 
3. Additional small parts for the built: (2x Resistor 82K, 1x Capacitor 220nF)
4. Arduino UNO or Compatible to program the Firmware
5. Arduino IDE Software to do so (https://www.arduino.cc/en/main/software )
6. Some Jumper wires (male – female) for example https://www.amazon.com/cables-

multicolor-alambre-tableros-arruinar/dp/B01EV70C78?ref_=fsclp_pl_dp_2 
7. The latest firmware file „QCX SSB.ino“ from https://github.com/threeme3/QCX-SSB 
8. Some additional small parts depend on the decisions you make down the road....

The tools required are the same, as for the original QCX Kit. 

Let´s jump directly into step one:
Place all the red components below and solder them in place. Look carefully to the tables on the 
next pages, for what value to place where and use the checkbox to verify, you did not miss 
anything. 

http://shop.qrp-labs.com/qcx
https://github.com/threeme3/QCX-SSB
https://www.amazon.com/cables-multicolor-alambre-tableros-arruinar/dp/B01EV70C78?ref_=fsclp_pl_dp_2
https://www.amazon.com/cables-multicolor-alambre-tableros-arruinar/dp/B01EV70C78?ref_=fsclp_pl_dp_2
https://www.arduino.cc/en/main/software
http://shop.qrp-labs.com/kits/LPF
http://shop.qrp-labs.com/kits/LPF


Start with IC´s and Crystal's:

28 Pin Socket

PCB Rev5 
Label

Place (QCX 
SSB 
Schematic)

Value (bold if changed) Remark Checkbox

IC2 IC2
for ATMega328P 
Controller

IC3 IC3 SN74ACT00N

IC5 IC5 LM4562A

XTAL1 XTAL1 20 Mhz

XTAL2 XTAL2 27 Mhz



Continue with capacitors

PCB Rev5 
Label

Place (QCX 
SSB 
Schematic)

Value (bold if changed) Remark Checkbox

C3 C3 0,1µF - 104

C29 C29 0,1µF - 104

C35 C35 0,1µF - 104
Solder a little higher on 
PCB, for easier step 3

C36 C36 0,1µF - 104

C30 C30 30pF – 300 for Multiband

C32 C32 10µF (electrolytic, Minus to GND)
leave out for Guido´s 
magic whitchery mod

C6 C6 0,1µF - 104

C33 C33 1nF – 102

C41 C41 0,1µF - 104

C34 C34 0,1µF - 104

C40 C40 0,1µF - 104

C42 C42 10nF – 103

C43 C43 470nF – 474

C44 C44 470nF – 474

C45 C45 470nF – 474

C46 C46 470nF – 474

C2 C2 0,1µF - 104

C48 C48 0,1µF – 104

C7 C7 1nF – 102

C4 C4 1nF – 102

R11 C39 0,1µF – 104

R58 CXX 220nF not in Kit !

C37 C37 10µF (check Polarity)

C38 C38 10µF (check Polarity)

C51 C51 10µF (check Polarity)

C47 C47 470µF (check Polarity)



Continue with resistors:

Remark: If you don´t have 82K Resistors, you can put in Series:
68K + 15K = 83K
56K + 27K = 83K
Most important: R7 and R10 need to be the same Value. 
Less then 82K = Less Gain / More then 82K = More Gain, but you lose dynamic Range.

270 Ohm

100 Ohm

100 Ohm

100 Ohm

100 Ohm

PCB Rev5 
Label

Place (QCX 
SSB 
Schematic)

Value (bold if changed) Remark Checkbox

R65 R65 3,3KOhm

R48 R48
Alternative 1,2K for 
less Brightness and 
Current

R41 R41 470 Ohm / in Rev 5 150Ohm
leave out for Guido´s 
magic witchery mod

R42 R42 1K / in Rev 5 1,2K 
leave out for Guido´s 
magic witchery mod

R1 R1 10K

R2 R2 10K

R3 R3 1K

R4 R4 1K

R53 R53 1K

R54 R54 1K

R51 R51 10K

R57 R57 10K

R56 R56 10K

D4 R(D4) 10K

R44 R44 3K3

R45 R45 1K

R46 R46 10K

C9 R49 10K

R7 R7 82K not in Kit !

R10 R10 82K not in Kit !

R5 R5

R6 R6

R8 R8

R9 R9



Finish step one, with the final parts:

You can also put in the screws and spacers for the display, and solder in Male/Female 16 Pin 
connector to your Display PCB.

Switches

ISP ISP

PCB Rev5 
Label

Place (QCX 
SSB 
Schematic)

Value (bold if changed) Remark Checkbox

L5, L6 L5,L6
100µH (47µH in Rev 5 – not 
critical)

fixed Inductors

L4 L4 1µH / 16 Turns (on T37-2 -red) For Multiband

D3 D3 1N5189
(Alt: Wire Bridge, if you 
know what you do – for 
Current Saving)

D1, D2 SD1,D2 1N4148

Q6 Q6 MPS751
leave out for Guido´s 
magic witchery mod

Q1,Q2,Q3,
Q4,Q5

Q1,Q2,Q3,Q4
,Q5

BS170
leave out Q4 for Guido´s 
magic witchery mod

IC11 IC11 Voltage Regualtor 7805

R47 R47 Trimmer Poti 100K

S1,S2,S3 S1,S2,S3

SW1 SW1 Rotary Encoder

Paddle/Ear
phone

Paddle/Earph
one

3,5mm Jacks

Power 
Connector

Power 
Connector

Power Connector

RF Jack RF Jack BNC Socket

Display 
Connector

Display 
Connector

16-Pin Male -Male on PCB

6 Pole Connector



Step 2:
Place 10K resistor at right side of PCB Label R52
Place 10K resistor at Pin 5 of PCB Label IC7 (lower right pin)
Connect the 2 legs of the resistor, and wire them to Upside of C35 (Side towards IC2)

Should look like this (without black and white wires, which will be step 3):



Step 3:
Solder a Wire from left Pin of PCB C23 to Right Pin of PCB R14
Solder a Wire from left Pin R11 (Which is now C39) to middle Pin of PCB R27

Should now look something like this: (black and white wire)



Step 4: 
Place Resistor 1K between Pins 3 and 4 of PCB Pattern T1
Place Resistor 1K between Pins 6 and 8 of PCB Pattern T1
Place Capacitor 10nF between Pins 4 and 8 of PCB Pattern T1

It´s hard to take a detailed picture of this, but you should get the Idea....



Step 5:
Finally some wiring on the soldering Side of PCB:
Colors are up to you, but for description I will refer to my chosen colors....
Yellow wire connects IC2 Pin 18 to lower Side of C42
Brown wire connects IC2 Pin 20 to middle Pin of DVM Pins on PCB
Blue wire connects IC 2 Pin 21 to lower Pin of DVM Pins on PCB.( In my case I soldered this one 
to upper leg of C 35, because it is directly connected to IC2 Pin 21)

If you want to use Headphones, or active speakers, solder in 470 Ohm resistor between IC2 Pin 15 
and IC10 Pin 1. If you prefer passive speaker, place another wire instead.



Step 6:
Now we need to take care about the Low Pass Filter.
For operation without unwanted harmonics, you need a Low Pass Filter, matching the Band of 
Operation after the Finals. There are several Options. 

Option 6a) 
You could use the LPF Components, supplied with your Kit.
Simply use the components supplied with your Kit and place them according to Original QCX 
Manual. However this would make a „kind of“ Mono-band QCX-SSB. If you build one for highest 
Frequency you want to use (For Example 10m or 20m), then you could add additional Filters (Off 
PCB) for Lower Frequencies. (30m,40m,60m,80m.... You get the idea.) The relays board from QRP 
Labs for example works this way. However, you always will have loss of 2 filters this way, with the 
exception of your highest used frequency.

I´v taken all those possible values for QCX LPF, and put them together in one Table for you:

Band
27 25
24 23
24 21
20 19
17 16
15 13

QCX LPF C25/C26 C27/C28 L2 L1 & L3
Value Value Toroid Value Windings Toroid Value Windings

80m 1200pF 470pF T37-2 3,0µH T37-2 2,4µH
60m 1200pF 680pF T37-2 2,3µH T37-2 2,1µH
40m 680pF 270pF T36-6 1,7µH T36-6 1,4µH
30m 560pF 270pF T36-6 1,3µH T36-6 1,1µH
20m 390pF 180pF T36-6 0,9µH T36-6 0,77µH
17m 270pF 100pF T36-6 0,67µH T36-6 0,55µH



Option 6b)
External LPF, still using QCX BNC Socket for Antenna Output. You could insert external Low Pass
Filters, and still use the On-Board RF Out BNC Jacket to feed the Antenna:

Use PCB C27 to feed Input of external LPF
Use PCB C28 to feed back Filtered RF to BNC Jack
Red is RF, and Blue is GND.
If you -eg solder Coax Cable there- red needs to be inner wire, and blue needs to be shield.

This would be an example, where I soldered wires on component side of PCB with connectors to 
the points shown above, and simply plug in external LPF´s. This way I had to extend display 
connectors. This can be avoided, by soldering the LPF connections on the Downside of the PCB.



Option 6c)
Wire final Transistors directly to BNC-Jack and use external LPF´s in Coax Line. Like this:

There are other ways to do it, but this way, you can use un-isolated wires with low chance of 
shorting something.

Then you need to get your LPF´s into Coax Line. I´ve build a small PCB, with 2 BNC Jacks, where 
I can plug external Low Pass Filters by QRP Labs:



Optional Step 7: Guidos secret magic witchery mod..... ;)

Sounds interesting, uh ? I was aware of this Version of the Schematic, but since it was only a 
footnote in Guido´s original instructions, I ignored it. Bad Mistake...... (See Notes 3 on his Github 
Page)

It uses even less components, and allows software control over working point of PA. This way you 
can tweak for optimum efficiency of your PA by Menu Setting 8.3 “PA Bias Max”. I was able to get
more Output-Power with less Input Current. Technically it adjusts the gate voltage of you PA Fet´s. 
Recommended Maximum Value for this setting is 128. Less is more. You have to measure DC 
input Current at the same time as Output Power, to find your optimal working point.

But unfortunately it requires destroying one PCB Trace. So no way back from here....

If you already built the QCX SDR/SSB from one of my earlier Versions of instructions, you need to
remove a few Parts: Q4, Q6, C31, R41 and R42.
If you´re building it from Zero, you probably saw the remarks (Leave out for Guido´s magical 
witchery mod) 



After that, you need to interrupt the Connection at Pin 3 of IC3 at soldering side of PCB:

Solder in Bridge between outer Pins of Q6 Pads. Place 10nF Capacitor into outer Pins of PCB Q4, 
Place Resitor 10K from Middle Pin of Q4 to Outer Pin of Q4 (BNC-Jack Side of PCB)



Next: Solder 10nF Capacitor beween Pin 3 of IC 3 and Gate-Line of PA-FET´s Q1-Q3, 
Solder in 10K Resistor beween Outer Pin of PCB Q4 (the Pin with already 2 wires through hole) 
and Gate Line of PA-FET´s Q1-Q3.

Ignore the Jumper Connectors, which might not be there at your PCB´s. I epoxied them in Place as 
Socket for my external LPF´s (See Step 6b).

And the Mod is finished.



Step 8:
Making it alive.... or putting firmware on it....
Before that, you should of course place the ATMega into the 28 Pin Socket.
Programming it is actually pretty simple, if you carefully follow step by step.
First you need to install Arduino IDE (Source: https://www.arduino.cc/en/main/software )
Then you need to Download the Firmware File „QCX SSB.ino“ from 
https://github.com/threeme3/QCX-SSB 
When you´re using Guidos source code (The INO File, instead of the Hex File) there´s no need for 
an additional software tool...

So, you installed Arduino IDE, and have Arduino UNO connected to your computer by USB ? Let´s
get started. If your Installation is working, by double clicking the Downloaded „QCX SSB.ino“ 
Arduino IDE should start and should look like this. Except for your language ;)

First thing to do is choosing your Board (Tools → Board → Arduino Uno):

https://github.com/threeme3/QCX-SSB
https://www.arduino.cc/en/main/software


followed by setting the right com Port for your Arduino UNO:

After that, you should see something like this in the lower right corner of the Arduino IDE Window:

Next, you need to prepare the Arduino UNO, so it will serve as Programmer for the QCX.

To do so choose File → Examples → ArduinoISP → Arduino ISP



A new sketch window will open.
In this Window, first select Tools → Burn Bootloader. 

When this is done, select Tools → Programmer → AVR ISP 



Then you need to push this button:

and after a few seconds, the Arduino UNO will be ready to serve as Programmer for our QCX.
We can close our Arduino ISP Window now, as we don´t need it anymore, and we now should have 
only QCX SSB Window remaining.

Now disconnect the Arduino from PC (USB) and connect the Arduino UNO and the QCX by using 
the wire bridges. (Male / Female)
This Picture from QRP-Labs Manual shows how:



This is, how it looks in Hardware:

After you have double checked, that the wiring is right, you can connect Arduino´s USB cable to 
your PC again, but do not yet Power up the QCX !

Tip:
Once you have placed the Pins on the ISP interface, you can tape the pins together. This way you 
have a cheap “connector” and do not need to fiddle around for future Updates.
Just remember the orientation...... 



Board Settings and Com Port should still be the same as before, but we need to change the 
Programmer now, as we use the UNO to program the external QCX now. Choose Tools → 
Programmer → Arduino as ISP

Next Step is to power up the QCX by external Supply Voltage first, and then burning the Bootloader
again, but this time to the QCX:



And after that has been done, finally we will send the firmware to the QCX by using Upload with 
Programmer. This is very important, otherwise you´re Programming the Arduino UNO, and not 
your QCX ! Ask me, how I know this.... ;)

And after removing the ISP cable and a reboot, if you did all your soldering correct, and Adjusted 
your Display Brightness by R47, you should see the Menu of the QCX SSB, and your adventure 
starts.



To connect a CW Key, you need to solder a special cable or re-solder your plug, because the 3,5mm
(1/8 Inch) 3-Pin Plug is not in the usual layout.
Only straight keys or external keyers can be used. 
Those need to be connected like the PTT switch (Middle to GND) from Picture below. PTT and 
Key share a common Pin. 

Microphone should be connected as below. LED and Resistor are optional, not required.

Picture Source: https://x1m.fandom.com/wiki/Microphone_pinout?
file=X1M_mic_pinout_diagram.jpg 

I used an old cheap microphone that was left from Yaesu VX-7R. I re-soldered a 3,5mm Stereo 
Plug, and I had to change the internal wiring to PTT and Mic to match the diagram.

73 Manuel; DL2MAN

Thanks to Guido, PE1NNZ for his modification and his help so far !
Thanks to Hans, G0UPL for his Original QCX Project, and his friendly permission to use his 
Pictures from the manual.

The future of this Project is the µCX (micro controlled Transceiver), which we want to build 
on with a designated PCB. Join the discussion at   https://ucx.groups.io/   

http://ucx.groups.io/
https://x1m.fandom.com/wiki/Microphone_pinout?file=X1M_mic_pinout_diagram.jpg
https://x1m.fandom.com/wiki/Microphone_pinout?file=X1M_mic_pinout_diagram.jpg


Versions:
Version 1.1, Added “Guido´s magic whitchery mod
Version 1.02, regaining missing X2, added wire instead of Resistor for audio path, added Tape-Tip, 
changed L4 Toroid (tnx Ryan Flowers)
(DL2MAN, 20 May 2020)
for QCX PCB Board Revision 5 and QCX SSB Firmware 1.02d
Version 1.01 of the Manual, minor corrections, added Mic and Key (DL2MAN; 08. May 2020)
Version 1.0 of the Manual, First Release by DL2MAN
for QCX PCB Board Revision 5 and QCX SSB Firmware 1.02a


